1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

170-500mm Sigma problem on my D2x

Discussion in 'Lens Lust' started by vincebeus, Dec 28, 2005.

  1. Hello,

    I lend a 170-500mm F/5-6.3 Sigma lens. I have option to buy it. So i tested it on my D2X and from the 100 shots i made in two days. All photo's are out of focus.

    I used tripod and tried different iso for higher shutter speeds. I had shutter speeds between 500 and 2000. None of the photo's are in focus or sharp. I used the lens with B+W haze uv filter and with B+W polarization filter and without a filter.

    I don't know what can be wrong. Every other lense i use works good on my
    D2x. So can it be a lens issue? Or any other reason that it works so bad on my D2x?

    -------------------------------------
    Edited 2005-12-30 Reason brought back this lens and decided not to buy it. I tested it on 200mm against 70-200mm and 80-200mm both on 200mm. All on F/8 and i said to my self it will defeaneatly not be as good as the other two lenses. But atleast 75 procent result of the other two lenses. And it still gave me soft images and strange focus results. So i ended up bringing back the 170-500mm Sigma lens. And buying a 2nd 24mm with a fisheye convertor from kenlock that i want to use on my 50mm F/1.4 lens and i bought a 55mm F/2.8 Micro lens.
    -------------------------------------
     
    Last edited by a moderator: Dec 30, 2005
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.