Accessing MacBook Pro from iMac

Joined
May 5, 2005
Messages
24,537
Location
SW Virginia
I can't seem to access my MacBook Pro from my iMac as I have in the past. I open Finder, click on Go -> Connect to Server and enter smb://(IP address) and press enter. It pops up a window requesting my username and PW on the MacBook, but when I enter it it just gives me the head shake signifying an incorrect password. I know I'm typing the PW correctly.

I've done this many times in the past with no problem. I have recently upgraded the MacBook to Mojave while the iMac is still running High Sierra. Could that be the problem?
 
Joined
Mar 25, 2011
Messages
3,193
Location
London
I can't seem to access my MacBook Pro from my iMac as I have in the past. I open Finder, click on Go -> Connect to Server and enter smb://(IP address) and press enter. It pops up a window requesting my username and PW on the MacBook, but when I enter it it just gives me the head shake signifying an incorrect password. I know I'm typing the PW correctly.

I've done this many times in the past with no problem. I have recently upgraded the MacBook to Mojave while the iMac is still running High Sierra. Could that be the problem?
What about this? https://discussions.apple.com/thread/8616638
 
Joined
May 5, 2005
Messages
24,537
Location
SW Virginia

Thanks, Morty. It was not totally straightforward, but some information in that thread did lead to the solution. You not only have to have File Sharing checked on the Mojave computer, you have to go into Options and check which user's files are to be shared and enter a password.

Apple could (should) have provided a better error message. Just the head shake that you get for a bad password attempt was very confusing.
 
Joined
Oct 15, 2008
Messages
2,517
Location
GA
Thanks, Morty. It was not totally straightforward, but some information in that thread did lead to the solution. You not only have to have File Sharing checked on the Mojave computer, you have to go into Options and check which user's files are to be shared and enter a password.

Apple could (should) have provided a better error message. Just the head shake that you get for a bad password attempt was very confusing.
You shouldn't have to do any of that.

Once in File Sharing, add the user for that machine and set it to read/write. (it should already have either Staff, Everyone, or both in the list). The username/password for that user is what you'll use when connecting to it remotely.

On your side, instead of trying to connect via IP, just select Go --> Network and that computer should show up in the list. When the prompt comes up to connect to it, choose "Registered User" and put in the UN/PW. You can choose "remember this password in my keychain" for quick connections.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom