1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

Any XP SP3 users?

Discussion in 'PC/Windows/Linux' started by Bill N, Jul 13, 2008.

  1. Bill N

    Bill N Guest

    Just checking to see if anyone had d/l SP3 for XP? I checked MS but didn't see a link to d/l. There are other places but I'm not real comfy d/l this kind of thing from an unknown site. Thanks for any details you can send my way. Bill
     
  2. yeah I have it

    just go to Microsofts Windows Update site - it should automatically ask you to update to SP3
     
  3. Bill N

    Bill N Guest

    Well now I feel silly! For some reason I thought I was still running sp2. I'm looking around the update site.... I can't find a way to d/l sp3 on the pages that should have it. Must be they are more aware than I am of what I am running. Right click my computer and look at properties, yup, I already have sp3.:rolleyes:  The older I get the more I forget!! Take care, thanks for the fast reply. Bill
     
  4. I have put SP3 on a number of computer, and I've only run across one issue. On certain HP models equipped with AMD processors, a file updated in SP3 can cause a blue screen before windows completely loads. The file being loaded during startup is for Intel processors only. There is a registry change that needs to be made in order to avoid this problem.

    All the other systems I've used it on, other than that ~3 year old HP have worked great, be they AMD or Intel based. I haven't noticed any new bugs or annoyances in SP3, and it runs just as smoothly as SP2 did (i.e. tons better than Vista, LOL)

    Here is a link to download the entire service pack installer: http://www.microsoft.com/downloadS/...A8-5E76-401F-BE08-1E1555D4F3D4&displaylang=en

    This is the file I use to update multiple PC's, so they each don't need to download the SP separately.
     
  5. Bill N

    Bill N Guest

    Must have been typing the same time as you were, Peter. Yup, I already have sp3. I use FF 99.9% of the time. I do try and log into MS once a week with IE just for updates. Thanks again guys!
     
  6. Bill,

    I have run SP3 on three DELL computers for over a month without any known issues.

    Tom
     
  7. I have updated 3 machines, two desktops of questionable decent and my Dell D800 Latitude Laptop. NO issues runs really well.
     
  8. nykonian

    nykonian

    570
    May 4, 2007
    New York
    I put SP3 on all my machines at home and at work... no issues or whatsoever.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.