1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

Bizarre (to me) MacPro behavior

Discussion in 'Apple/Mac' started by Rich Gibson, Aug 16, 2009.

  1. I was using R-Studio to restore some lost files and (probably due to my mis-reading the instructions) the program apparently started filling up the boot drive till it filled up completely. I say that because the empty external drive I prepared stayed empty and the boot drive filled up. Funny thing is I couldn't find any .jpg files on the boot drive.

    Then the bizarre behavior started. I couldn't drag anything to a folder in order to start emptying the drive. I started Superduper to copy the boot drive to a larger backup drive. It erased the drive..then locked up. :eek:  I couldn't get it to copy anything over to the back up boot drive (the selection were all grayed out) Talk about Catch 22. Fortunately mu-commander let me move some stuff. Once I moved the Parallels files over I ran the Disk Utility and started with repairing permissions and it must have generated 1000 or more file permissions bad.

    Any ideas? Should I reinstall the OS?

    Thanks
     
  2. Can you run Disk Warrior to check your directory and check your drive for bad blocks? I wonder if your hard drive is failing.

    Good luck,
     
  3. I still don't know what caused it but the drive was completely filled up..zip remaining, nada! I couldn't click and move anything ostensibly because of this. Approximately several hundred files' permissions were clobbered as well. I tried to fix them but on subsequent queries the same broken permissions came up. I had to use the Leopard disk to fix the drives, but all is fine.

    Paul (Aka Paul Montydog) suggested a graphic package which displays the hard drive memory as a colored mosaic; I quickly found all my music, an old Aperture library, Garmin maps of north America and Europe and the Parallels database. I cleared up 50gb of space. :eek: 
     
  4. It's not too surprising that "interesting" things happened with a completely full boot drive. OS X, like most modern operating systems, operates with the requirement of there being some disk space available for virtual memory use and for simple temporary space. Unless you tinker with under-the-hood configuration files, that VM space is on the boot drive for OS X.

    It sounds like you freed up some space, but a good way around this problem again (if R-Studio every freaks out on you again) would probably be to boot from a different volume, and then access your normal boot drive to free up some space. It's not likely that the drive itself is damaged, though.

    Besides, you have an up-to-date backup of all your important data anyway, right? :cool: 
     
  5. Yep, two additional copies of the data drive and image drive.

    Boot 1&2, Data 1,2,3, Image 1,2,3.

    :wink:
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.