1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

D2h problem

Discussion in 'General Technical Discussion' started by bluesmangraham, Aug 15, 2008.

  1. Hi all, I hope someone can advise on a problem i'm having with 1 of my d2h cameras!, I have a Sigma 28-70 f2.8 lens which when i put on one of my d2h bodies (latest firmwear) focuses as normal ie hunts & locks. however, when I put it on my 2nd d2h body (latest firmwear) it refuses to hunt & i have to press the AF(any one including vertical & AFon) a number of times to get it to focus?, However, when i put on my Sigma 70-200 f2.8 on either body they both react as normal & quickly aquire focus on subject, the same with the 300?, is this a lens issue or has anyone had this problem with there D2h?. Both cameras have exactly the same settings set & fired under the same conditions. Thanks for any help. Graham
     
  2. joe_boyd

    joe_boyd

    75
    Aug 10, 2006
    Make sure all the electircal contacts are clean on the second (malfunctioning) D2H, and on the wide zoom. You can use a rubber pencil eraser to clean the contacts. Try to hold the body such that the eraser residue falls out of the camera. Don't attempt to use a blower to remove the eraser residue. Use a brush or your finger to keep the residue from dropping into the mirror box. Same thing with the lens.

    Good Luck!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.