D2X firmware update problems

Discussion in 'General Technical Discussion' started by SteveK, Nov 9, 2005.

  1. SteveK

    SteveK

    Mar 16, 2005
    Alaska
    I have 2 D2X bodies. I am using new Lexar CF cards (1, 2, and 4 GB). I am using a Dual 2Gz G5 computer running OS10.3.9. I tried reformatting, and erasing each of the cards. I downloaded the firmware update (three times, in case one of them was corrupted) using a DSL internet connection. I get two files, A (260KB) and B (3.7 MB) after decompressing the .sit file with Stuffit Expander.

    Now, when I put A on to a CF card, put it in a body, and hit "Upgrade", and Enter, the upgrading screen flashes briefly, and then the screen returns to the normal menu. The upgraded firmware does not install. This is exactly the same for each body, and I've tried each of my Lexar cards.

    Any suggestions? I've already sent an e-mail to Nikon Tech, but some of you guys may know the solution.

    Thanks in Advance! Steve
     
  2. You could always try the .zip file - the one listed for Windows. Stuffit will happily decompress it for you.

    Perhaps the .sit file is corrupt at the server?
     
  3. MontyDog

    MontyDog

    Jan 30, 2005
    #1064 - You have an error in your SQL syntax;
     
  4. DanWhite

    DanWhite

    Jul 10, 2005
    Lansdale PA
    I think you need to format the card in camera, not on the computer.

    Dan
     
  5. SteveK

    SteveK

    Mar 16, 2005
    Alaska
    I've reformatted the cards in the computer and in the camera. I've tried tethered with a USB to the camera, and using a card reader. I downloaded the windows version and the Mac version of the firmware update. The files appear to be identical, and neither A file will load into either camera with any of the three Lexar CF cards I have. The current firmware showing in the cameras is 1.0. When I select update, it shows that 1.01 is there, and the camera asks if I wish to update. I select Yes, enter, and the update screen flashes for about 1/2 second, and then it returns to the menu. It does not update. Same thing happens with both D2X bodies, with any of the three Lexar cards.
     
  6. Just a shot in the dark, but did you copy the files to the card with a Lexar Jumpshot USB cable? Nikon says you shouldn't do that, but I have no idea why.

    Here's a screenshot of the web page with that note in the instructions for upgrading:

    original.
     
  7. SteveK

    SteveK

    Mar 16, 2005
    Alaska
    I have a Star Tech Com card reader. I also tried loading the firmware via the USB connection to the cameras. Both put the firmware software on the CF cards, neither will load into the camera. I only have tried to load the A file, as the instructions indicate to load A first, then B. Again, when I select the new firmware on the menu, I get a 1/2 second flash of the uploading screen, then it returns to the menu, and firmware has not upgraded.
     
  8. nfoto

    nfoto Guest

    Numerous people have upgraded using the Windows version. To the camera this shouldn't matter because the *.bin files are - well - in binary format. But, Mac and PC have different "bin" formats (Little and Big Endian) and there is the possibility that the downloaded file was OK, but the unstuffing corrupted it locally.

    Bite the bullet and ask a friend with a PC to download the installer and unzip the "A" and "B" files to two CF cards (formatted in the camera). Upgrade should be a breeze.
     
  9. I had the same problem with my D2H... The problem was I downloaded the firmware in the wrong folder/place on my CF card.
     
  10. SteveK

    SteveK

    Mar 16, 2005
    Alaska
    OK, so can someone offer to send me an A file that worked in their D2X? I only need one copy, so rather than post my e-mail here, I'll wait until someone offers.
     
  11. Steve S

    Steve S

    Feb 1, 2005
    SE Florida
    Send me a PM w/your email addr, and I'll shoot it right over to you. worked fine in my D2X last night.
     
  12. nfoto

    nfoto Guest

    I have the A and B files. A is small and B is about 4MB.
     
  13. Is your battery at 99%??

    The first time I tried the D2X firmware upgrade it wouldn't work because my battery was at about 88%. I put in a battery at 99% and it worked fine. Just a thought....good luck !!
     
  14. last night when I upgraded my battery was at 80% and it still let me upgrade with no problems...



     
  15. I would be willing to bet good money that you did not drag the file to the root directory of your compact flash card. There are not that many things that can be done wrong and this is probably the most common. It is an easy mistake to make and I bet you are not the first or the last to do it. I hope it is that simple for you and I hope I was able to help.

    Good luck
     
  16. SteveK

    SteveK

    Mar 16, 2005
    Alaska
    I have the file on the root level of the CF card. I tried an A file from SteveS that worked in his D2X. I still have the same problem with both D2X bodies. The firmware upgrade shows in the menu, but when I select Yes, and Enter, the upgrade screen flashes for about 1/2 second, and it returns to the main menu. Firmware is not upgraded. Guess I'll wait for Nikon support to answer. Batteries were at 99% and 98% respectively.
     
  17. JeffKohn

    JeffKohn

    Apr 21, 2005
    Houston, TX
    There's also a disclaimer in the instructions about only using officially supported CF cards. Normally I would think this is just standard CYA legalese, but maybe you need to try a different type of CF card?
     
  18. SteveK

    SteveK

    Mar 16, 2005
    Alaska
    The three Lexar cards I have are all listed as ones which work for the D2X, and they have been working perfectly in the cameras since I bought them. These bodies have each had several thousand exposures, and I am not entirely new to digital cameras, or computers. Just this firmware upgrade is eluding me.....
     
  19. Is it possible to bring your camera back to where you started before you had problems and download the version 1.00. I am guessing, but possibly there was a corrupt file or something wrong with the original version that just didn't show up until you tried to upgrade to V1.01. Just a thought. I hope Nikon can offer a quick fix for you over the phone. I know how frustrating this must be for you.
     
  20. SteveK

    SteveK

    Mar 16, 2005
    Alaska
    Nikon Tech support was as puzzled as I am. The fact that two bodies do the identical thing, and that I have tried three different CF cards in each of the two bodies, and that I have tried the Mac, Windows versions, as well as one from another Nikon Cafe member that worked for him just doesn't make sense. The tech guy went over the installation step by step, and when I told him that nothing was happening, he didn't know what to do other than to send my cameras in to Nikon. They told me to call again tomorrow to see if anyone else there can figure out what's going wrong before sending my 2 bodies to Nikon Service.
     
Loading...
Similar Threads Forum Date
Sandisk Extreme III / D2x malfunction issue General Technical Discussion Sep 19, 2008
UNI White Balance & D2X General Technical Discussion May 22, 2008
Nikon D2X General Technical Discussion Apr 28, 2008
D2X firmware update thoughts General Technical Discussion Jun 30, 2006
Firmware Upgrade of D2X and D2HS General Technical Discussion Nov 8, 2005