D300 not recognizing the correct lens

Joined
May 26, 2011
Messages
484
Location
Louisville, KY
I'm trying to help my father with a problem he is having with his D300. He brought his camera over so I could help him AF tune his lenses. For some reason some of his images have been very soft.

Started tuning a 35-70mm lens and the first issue I saw was in the AF tune section of the menu it was saying the lens was a 70-14mm F1.2 lens. Put the Sigma 50mm 1.4 lens on and the camera still thought it was a 70-14mm F1.2. Tried a few images and some of the EXIF data was showing 8mm F1.0 and others were showing 3000mm F95. I still have the images with the EXIF data.

Here is the data in one of the last images we took:

File name : VPP_1270.JPG
File size : 5615402 bytes
File date : 2012:09:25 20:30:06
Camera make : NIKON CORPORATION
Camera model : NIKON D300
Date/Time : 2012:09:25 20:30:06
Resolution : 4288 x 2848
Flash used : No
Focal length : 3000.0mm (35mm equivalent: 4500mm)
Exposure time: 0.017 s (1/60)
Aperture : f/95.0
ISO equiv. : 200
Whitebalance : Manual
Light Source : Flash
Metering Mode: matrix
Exposure : program (auto)
GPS Latitude : ? ?
GPS Longitude: ? ?


Has anyone seen this before? Contacts on the camera and lens looks clean. We tried a reset of the camera but the same issue occurred. The other strange issue is with AF Fine tune enabled the camera would not turn off. Had to remove the battery to turn the camera off. With AF Fine tune disabled this problem went away but the camera was still reading wrong aperture and focal length.
 
Joined
Jul 11, 2009
Messages
1,379
Location
WICHITA, KS
I have 2 -D300 and have friends with the same camera....never have seen this happen at all and I have done AF fine tuning on my lenses also...

It might seriously need to go into a Nikon Repair shop.
 
Joined
May 26, 2011
Messages
484
Location
Louisville, KY
Yep. He bought a D7000 to replace it today and he is going to send the D300 back to Nikon for repair. Acting real weird. When he plugs in his wired remote shutter release in the menu won't come on. The camera won't turn off sometimes.

Went through some pictures of his before we started tuning the lenses and the camera thought it had a 15mm F1.2 lens.
 
Joined
Feb 15, 2012
Messages
524
Location
Minneapolis
Haven't heard of such an issue before, but now I'm stuck lusting over what could be done with a 15/1.2 if such a thing existed for DX or FX sensors.

Might be a faulty aperture control lever. If so, shipping to a repair center would be in order.

The body should read the lens data electronically rather than mechanically.
 

Latest threads

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom