D5500 Viewfinder issue

Joined
May 5, 2005
Messages
21,454
Location
SW Virginia
I just got a like-new D5500 from MPB.com. Everything appears perfect except in the viewfinder display where the shutter speed should appear there are unreadable characters. It's like the first two digits are only partially showing.

Any ideas?
 
Joined
May 5, 2005
Messages
21,454
Location
SW Virginia
It appears that the second digit from the left in the shutter speed display is missing some parts. For example, if the SS is 1/1000 it shows 1#00, where the "#" is just two parts of the 0.
 

kilofoxtrott

European Ambassador
Moderator
Joined
Dec 29, 2011
Messages
8,171
Location
Tettnang, Germany
Real Name
Klaus
Seems to be two possiblities:
- Internal software problem
- the display is faulty

Jim, I would send it back and ask for guaranty or replacement.

All the best
Klaus
 
Joined
May 5, 2005
Messages
21,454
Location
SW Virginia
Seems to be two possiblities:
- Internal software problem
- the display is faulty

Jim, I would send it back and ask for guaranty or replacement.

All the best
Klaus
Thanks for the suggestion, Klaus, but it's now too late for me to do an immediate exchange since my wife and I are leaving for Costa Rica tomorrow and we need this camera. I have e-mailed MPB.com about the problem but have gotten no response yet. I hope they'll make it right after we return, but I'm beginning to lose faith in this company. My problems are detailed in another thread.
 

kilofoxtrott

European Ambassador
Moderator
Joined
Dec 29, 2011
Messages
8,171
Location
Tettnang, Germany
Real Name
Klaus
I believe that issue has no influence on the pictures you'll shoot.

Enjoy your trip and kind regards to your wife
Klaus
 
Joined
Mar 25, 2011
Messages
2,236
Location
London
Thanks for the suggestion, Klaus, but it's now too late for me to do an immediate exchange since my wife and I are leaving for Costa Rica tomorrow and we need this camera. I have e-mailed MPB.com about the problem but have gotten no response yet. I hope they'll make it right after we return, but I'm beginning to lose faith in this company. My problems are detailed in another thread.
Have a safe trip and enjoy your travels.
Looking forward to your pictures.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom