1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

Fixed my Sigma 1.4 ext today: If yours feel's loose....

Discussion in 'Lens Lust' started by Sauk, Sep 28, 2008.

  1. Sauk

    Sauk

    832
    Aug 4, 2008
    Sandy, UT
    Ok so I kept getting errors because my ext was lose as hell when I put it on my 300mm Sigma Prime. So a few days ago I purchased some of those small screw drivers thinking there was a screw or two loose.

    Well I got them and proceeded to tighten the screws, the bad part they were all tight!

    I didn't have time to think about it on friday so today when I sat down and thought about it more I decided to take off the screws.

    So I took off the screws and peeled back the metal area to see if there were screws underneath I was missing. Well it turns out that beneath the metal top area are about 4 screws that keep it together (the lens is made of two sides).

    They were almost entirely off! I mean they almost fell out lol

    So I screwed those tight and it was like the first day I got it!

    I am so relieved to be honest. I thought I wasted 200 bucks. Turns out it was an easy fix.

    Here is an image of the screws and set of screw drivers I purchased


    103772537.gif
    Subscribe to see EXIF info for this image (if available)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.