1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

Flash not working

Discussion in 'General flash photography, lighting, and technique' started by coldwaterbeach, Jan 13, 2018.

  1. The built in flash on my D7200 has stopped working but when I use an add on flash it works as supposed to. Is there a setting that I may have turned off by accident? Or do I need to have my camera repaired?


    Gary
     
  2. Not clear what your problem is - what is it not doing? If I understand you, you are saying that the add on flash in the hotshoe will work, but the pop up gives no visible flash? If you go into the menu, there are adjustments that you can make to the onboard flash that may have created a situation where the flash won't flash visibly. That would be say in Commander Mode. If on the other hand, you set the flash to fire and popped it up and it is not in one of the "other modes" like commander mode and it does not visibly flash, the flash unit itself may be bad.

    My bet is that you inadvertently set something in the menu that turned off the visible flash. You say that your add on flash works. If it is a Nikon unit that "talks" to the camera, set the separate flash up as a remote, hold it off the shoe next to the camera and fire the onboard flash. If the add on flash fires, that shows that the pop up flash is in commander mode.

    RTFM would be my suggestion. Look at the menu under Section E for flash.
     
  3. I'm guessing the built-in flash is accidentally on commander mode where it will trigger a second flash but not contribute light to the exposure.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.