iMac and External Drive Problem

Discussion in 'Apple/Mac' started by rlacy, Jul 15, 2007.

  1. rlacy

    rlacy

    316
    Apr 22, 2007
    San Diego
    Got my new iMac on Friday. I have it hooked up and am slowly transitioning from the old iMac. Developed a problem this morning.

    I store all of my images on an external drive. Buffalo 500GB drive that connects via USB to the computer. I hooked it up to the new iMac last night and it worked fine. Printed a few images just to test. This morning the new iMac does not display/recognize the external drive. When I connect it to the old iMac, it recognizes it, shows it in Finder and I can access the images.

    Does anyone know why this would happen and what I need to do to get the new iMac to once again recognize the drive and make the information on the drive accessible? This is puzzeling. :confused: Any help/suggestions appreciated.

    Ron
     
  2. RaceTripper

    RaceTripper

    739
    Jan 6, 2007
    St. Louis
    Have you tried rebooting the iMac with the USB drive attached? I could be the USB bus needs to reset.
     
  3. dagored

    dagored

    285
    May 4, 2005
    Ohio
    Try this:

    Go to Utilities. Select Disk Utilities. Select First Aid if not already selected. Does the external drive show up? If so, select the internal iMac HD and Repair Permissions. If the external drive does not show up, change the USB cable.

    Tell me what happens or if this helps.
     
  4. I also had this problem with my WD external drive using Firewire 800. I switched to Firewire 400 and while it still does happen from time to time, it's not nearly as often as with FW800.
     
  5. Did you ever eject that drive? If so, the OS remembers that and does not remount it.

    To fix that, run the app Disk Utility in Applications -> Utilities. The panel at the left will have a list of drives and the volumes on them. If you see the Buffalo there, select it and use the Mount button at the top of the window.
     
  6. rlacy

    rlacy

    316
    Apr 22, 2007
    San Diego
    Thanks for all of your replies. Beezle, I think you were right in your solution. I got it fixed another way, but I think your solution would have been easier and it amounted to the same thing.
    Thanks again.
    Ron
     
Loading...
Similar Threads Forum Date
faster iMac editing. Apple/Mac Yesterday at 6:43 PM
New iMac Pro - for photographers? Apple/Mac Thursday at 12:42 PM
24GB or 32GB of RAM for iMac Apple/Mac Nov 27, 2017
New Passport External Drive drawing more current than iMac provides. Apple/Mac Jul 10, 2015
Help pls - which external hard drive for Imac? Apple/Mac Dec 15, 2009