New minor annoyance with Safari

Discussion in 'Apple/Mac' started by Rich Gibson, Jun 28, 2007.

  1. I recall seeing an update for Safari recently and wonder if it is the cause of a new "glitch." All of a sudden now I'm getting rectangular outlines of window boxes sticking on the screen. For example as I type this post the "Title" box has gotten a thick black line around it and it will stay there on the screen after I submit this thread.

    Update: yep after the post was added the rectangular box stayed in place. Oddly now that I'm editing this post the box disappeared. Weird!

    Any ideas?

    Thanks, Rich
     
  2. I use Firefox.

    You might try saving off a copy of Safari's prefs file at:

    ~/Library/Preferences/com.apple.Safari.plist (~ is your home directory)

    Then obliterating that and see if that helps.
     
  3. DrewC

    DrewC

    Jan 30, 2007
    Denver, CO
    try out "camino" very nicely integrated for macintosh users... worth a shot.
     
  4. ?
     
  5. Huh.... I haven't experienced that with my machines, Rich.... Don't know what could be causing it!

    ETA: I used to use Firefox on my Windows XP machine in order to avoid the problems with IE, but once I moved to the Mac, I liked Safari so much that I decided it was not necessary to use FF any more and have not even tried it. I, too, have heard good things about Camino but haven't tried it, either. On my Windows machine I found FF to be a bit cumbersome at times, but I don't know if it is the same when used on a Mac.
     
  6. I use Firefox on my Mac so that I can use the same browser on all the machines I have to use (Mac, XP and Linux).

    Did you update to the Safari 3.0 Beta test, Rich?

    Ronnie
     
  7. Donzo98

    Donzo98

    Nov 10, 2005
    Merrick, NY
    Rich....

    I had the exact same thing happening on FireFox. I was also getting freezes which required a hard restart of the computer. I got the spinning color wheel and couldn't do anything except move the mouse cursor. Everything else was frozen... even the clock.

    It is the first time I called Apple care since buying the G5 from YOU!!! :wink::wink: I tried to blame the problem on you... :biggrin::biggrin: but they werent having any of it.

    I have a program called Smart Scroll X which I disabled because I thought it the problem was happening when I scrolled. Since disabling the program two days ago... no more freezes. Im not 100% sure that was the problem...

    First I thought it was Firefox and then it happened using Safari too.
     
  8. Not sure this is the same problem I have read about on another forum. It was caused by activating some of the Universal Access options with some keystrokes. Check this section of your preference settings.
     
  9. No. 2.0.4 Build 419.3.

    Rich
     
  10. They're not activated.

    Thanks, Rich
     
  11. I've done some searching and haven't found anything.

    If you could give me a bit more information it would help:

    - which Mac?
    - OS build? (About this Mac window, click on the version just below "Mac OS X" and the build number will appear).
    - do you use tabs?

    If you could grab a small screenshot of the area around the "thick black line" it would help a lot.


    -
     
    Last edited by a moderator: Jun 30, 2007
  12. Mac Pro 3.0GHZ 6gb ram
    Mac OS X v 10.4.10 (8R2218)
    No tabs

    When I complete the post the title box window outline shows. So I go to grabit and when I select capture window on my left monitor the box automatically disappears in the Nikon Cafe window. I can't duplicate the defect without photographing it.

    [​IMG]

    Thanks, Rich
     
  13. This is a test

    Just trying to reproduce it.
     
  14. I believe that just because the box at the bottom is not checked it does not necessarily mean that none of the settings are activated. I use the enlarged mouse pointer from this System Preference so I can find it on the 30" ACD and the box is not checked. There are some keystrokes that can be hit inadvertently that turn on a box outline. I just wish I could remember what they are as hitting them again turns it off. You might try a search over at macosg.com or a post there to see if anyone else has a memory.

    :smile:
     
  15. Looks like the outline drawn around text edits drawn in the wrong place. But it doesn't seem to be the same size as those used on this web page.

    Is the line solid black? Or the highlight color (set in the Appearance System Preferences panel)?

    With your permission (to use the photo) I'll write up a bug and see what pops out.
     
  16. The boxes usually surround the text edit section or the title. The line is as it appears in the photo, solid black. Of course go ahead, and thanks. I edited this box and that rectangle appeared again right under the Nikon Cafe oval logo. I even switched to the "User CP" meu choice and the box remains under the Nikon Cafe logo.

    Rich
     
  17. TLochner

    TLochner

    140
    Jun 11, 2006
    SW Ohio
    Hello everyone. What you may try is repairing disk permissions and if that does not clear the problem boot from the cd and go into disk repair. I believe you should fix the problem that way. If I am not mistaken you have to hold down the C key when booting.
     
  18. Tom you are a guru for sure! That was it. The disk permissions corrected buy I couldn't repair the disk without using the install CD. There were header problems which finally got corrected. The mysterious boxes have disappeared. Thanks very much.

    Rich
     
  19. It would be extremely odd if that fixed it. Probably clearing the browser cache of NC data or something along those lines did.

    So long as they're gone. :smile:
     
  20. I spoke too soon. I was at another site and another magic box showed up. Aha! It only shows up when I go to edit an existing post.

    Rich
     
Loading...
Similar Threads Forum Date
Mackeeper...annoying and incessant Apple/Mac Aug 4, 2017
Safari Browser Acting Up - Help! Apple/Mac Feb 14, 2017
Wierd little iPad oddity/annoyance Apple/Mac Mar 13, 2015
Annoying OSX Lion Feature Apple/Mac Oct 16, 2011
OS X - clam shell mode annoyance Apple/Mac Aug 19, 2009