New TC1.4E II that rattles

Discussion in 'Lens Lust' started by Louis Champan, Aug 31, 2005.

  1. I just received my new TC1.4E II and when picking it up I noticed something was rattling. After taking the covers off I noticed that there is a small lever inside that freely moves back and forth when moving the adapter. After mounting it on my camera body (D70) the lever stablized with no free movement. And after mounting my 70-200VR everything appears to work properly, but it sure doesn't seem right to have something that loose in there.

    Any thoughts would be appreciated.

    louie
     
  2. I believe that to be normal. When you mount it on your camera it pushes a lever over and picks up the spring tension.
     
  3. Thanks Gordon, that puts my mind at ease. I was hoping that I wasn't going to have to go through the ordeal of returning it, etc. I'll give it a work out this weekend.

    louie
     
  4. cwilt

    cwilt

    Apr 24, 2005
    Denver, CO
    Normal.

    Mine does it as well.
     
  5. Louis, the first one I ever borrowed did that, and the one that I bought does that as well. Rest assured that this is normal. Enjoy your TC! That's a nice one.
     
  6. Thanks everyone, I really appreciate the fast response. This is a great forum.

    louie
     
Loading...
Similar Threads Forum Date
Teleconverter 20e ii Lens Lust Jul 12, 2017
Nikon 1.4TC ii or iii Lens Lust May 17, 2017
Non-Nikon manual focus lenses - Part II Lens Lust May 1, 2017
NIKKOR 16-80mm f/2.8-4E ED VR DX Lens Lust Jul 21, 2015
300 f/4E PF with 1.4 TCIII Lens Lust Feb 7, 2015