Nikon Release D300 Firmware 1.3

Joined
Apr 24, 2005
Messages
328
Location
Cincinnati, Ohio
In addition to the announcement of the D700, Nikon has revised the firmware of the D3 and D300. The latest D3 firmware adds new function button customization options though not the ones featured on the D700. In addition to these and a virtual horizon in live view mode, Nikon has also addressed the problem that some users experienced in which the battery indicator would incorrectly register an empty battery.
This problem, which has come to be known as 'Dead Battery Syndrome,' has also been addressed in new firmware for the D300.

D3 firmware makes improvements to AF and Auto White Balance mode, as well as correcting for the battery indicator errors. Many of the other changes are subtle tweaks to menus and behavior, such as the decision to only all auto-rotate of images in playback mode, not in the review image that appears after shooting (as the camera must already be in the correct orientation to have taken the shot).

The only D700 feature to appear is the addition of a visualization of the virtual horizon function to live view mode. Other than this, the new function button customization options are not as extensive as its new baby brother. The D3 changes add three more options that can be assigned to the Function, Preview or AE-L/AF-L buttons. The only completely original option is the ability to scroll between shooting menu banks (user-defined presets) with a button press and turn of the control dial. The firmware also separates the image area (FX/DX/5:4) option into two, so that you can choose to either scroll between all three image sizes or just between FX and DX.
 
Joined
Jul 16, 2007
Messages
34
Location
Texas
I've updated mine. It's quick and painless, but I didn't really notice that I gained anything. Anyone experiencing DBS able to confirm a fix with the FW?
 
Joined
Jul 12, 2008
Messages
31
Location
Colorado
Firmware update fixed my problem

I'm a new D300 owner and new member of Nikon Cafe. I was getting the DBS when trying to use my Kenko 2X Teleconverter with my D300 and my 105mm macro lens. The firmware update fixed the problem, so I'm a happy camper.

Jan Cabral
 
Joined
Feb 4, 2006
Messages
6,690
Location
On a Big Island Down Under...
I updated even though I didn't have any problems with DBS.. Working great...
The only thing I noticed is now when using the D300 in 14 bit mode, the shutter lags is virtually gone.
Where the shutter lag was really noticeable before (14 bit), its almost instant as if I'm in 12 Bit mode...
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom