1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

NX2:Gen - Commands - Access to file denied (NX 2)

Discussion in 'Nikon Capture and View NX' started by mikaels, Jul 9, 2008.

  1. mikaels

    mikaels Guest

    Hi,

    I'm having problems when I try to save my .nef files in Capture NX2. I get this error:

    Could not save file - Access to file denied

    but when I try to save it to another place it works well. I didn't have any problems before I updated to NX2...

    Regards,

    Mikael Svensson
     
  2. The most logical answer is that the file or directory is read-only.
     
  3. mikaels

    mikaels Guest

    But there is no problems when I'm using same files/directory on NX 1.3!
     
  4. otipher

    otipher

    8
    Jul 19, 2008
    NJ
    intermittent "access denied" and occasional lost files

    I have two intermittent file saving issues.

    1. Occasionally when trying to save an edited NEF file I get "access denied". The only way to save the file then is using "Save As".

    2. Occasionally when executing batch commands across a group of NEF images, one of them will be silently deleted. It takes a while to realize this is happening because there are no error messages shown.

    Both of these save problems occur on the local hard disk which has no save or permissions issues with any other windows application.

    Have others seen these intermittent issues. The second is more serious than the first for me as images are lost unless backed up elsewhere.
     
  5. Gaius

    Gaius

    67
    Jul 1, 2008
    U.S.A.
    I also experience intermittent save problems. It will happen to a file in a directory where I have been saving other files so it is not a directory permissions problem. I use ViewNX to browse files and launch NX2 from there and one possibility is that ViewNX has locked the file even though the file has only been browsed.

    It has not happen enough that I have diagnosed the cause but altering the save method generally works.
     
  6. JustEd

    JustEd

    Jul 21, 2008
    Sacramento, CA
    I am running NX2 on a iMAC G5 als, OXS 10.4.11 with 1 gig of system memory and have had not had "access denied" problem others complain about.

    It might be a good idea when posting computer related problems to let us know what flavor of NX2 you are running (MAC or PC) and what computer it is running on.

    With all that said, I have found that NX2 saves NEF files that have been edited very slowly at times. IT seems to depend on the number of edit steps applied, NX was faster on my machine.

    Ed
     
  7. Are you running any sort of sync software (like Foldershare, GoodSync, et.al.) ?

    I have been caught with this, because I use Foldershare which automatically backs up any changes to another computer. If I do two saves without enough time between them, the file is in use because it is being copied. Solution is to just wait a minute and then try the save again.
     
  8. otipher

    otipher

    8
    Jul 19, 2008
    NJ
    I am running Windows XP home with SP3.
    The problems started before I upgraded to SP3.
    I don't have any file sync software running.

    I looked through the Windows Event logs, nothing useful there that correlates with file saving problems.

    As others have posted this will occur in a directory where many other NEF files have been saved successfully.

    Its annoying, but the more serious issue is where running batch commands can result in a NEF image disappearing silently. It may be that the two issues are related. When the "access denied" issue occurs, the file you are trying to save no longer exists in the directory. If you don't use "save as" after getting "access denied" and quit out of NX2 your NEF file is gone...
     
  9. TomaS

    TomaS

    497
    Aug 3, 2006
    Corrales, NM
    This has happened to me a few times (NX2 on XP SP3) and again yesterday after 'tweaking' an image for 30 minutes. VERY irritating. I thought that I had lost all my edits.
    But i did manage to save the NEF with edits. Here is what I did.
    After dismissing the dialog box (OK!), the edit screen was still visible and all menu commands still functional. so i tried to 'save as' a JPG in another directory. IT WORKED! Then I did another 'save as' back in the original NEF directory with another filename. IT WORKED!
    Who knows why or when this happens. NX can be a flaky and unpredictable piece of software at times. but at least there seems to be a way to get around it.
     
  10. Tomas, I've had this a few times and it seems related to an overfull image cache according to some postings I read on another forum (or maybe here I cannot remember). I usually clear my cache before I start NX2.

    BTW, I could just save the file again and have no problems (using 'save as') as you also describe.
     
  11. I had the same issue. Called tech support and found it not to be a "permissions" issue, but rather an issue of saving the file to an external USB drive. Placed all my photos on an internal drive and problem solved. NX2 can be strange at times.
     
  12. g_glip9

    g_glip9

    10
    Sep 24, 2008
    brookline, ma
    There has been a discussion of just this problem in Nikonians: http://www.nikonians.org/forums/dcb...forum=196&topic_id=45434&mesg_id=45434&page=7

    In my case the problem was tracked down to an issue with my virus scanner (Avira), although others seemed to have a similar problem with other products. If I disable the scanning software I never have a problem. I'm on an anemic PC and am using Capture NX2. I've also had the problem with JPGs.
     
  13. I was having this problem recently, and wanted to make one suggestion which might help others.

    I found that if I attempt to save while the image is still rendering (e.g. I change some setting which takes a long time to process), this occurs more frequently.

    If I make sure that the little twirly progress thing completes before attempting to save, then it works 100% of the time.
     
  14. jhwalker

    jhwalker

    61
    Jun 10, 2008
    United States
    I've seen this problem several times, using NX2 on Mac (Intel) 10.4.x. When I take a look at the problem file, it is flagged read-only. Obviously an NX2 bug, as the file was not read-only *before* I started editing ;-)
     
  15. otipher

    otipher

    8
    Jul 19, 2008
    NJ
    update

    I thought I'd provide an update back to the group on my most recent experiences with this issue.

    Thanks to the poster who posted the link for the nikonians forum discussion. Modifying my anti-virus scanning software setup to ignore NEF files has fixed the access permissions problem for files accessed from the local hard disc.
    I've edited over 150 pictures from the hard disc without a single access error since modifying the AV setup.

    Unfortunately the problem still occurs frequently if editing files on an external drive (networked server driver in my case). Another poster notes the same problem with an external USB drive.

    To the poster who found some files were set to "read only" - I had some of these and eventually determined that these were a result of accidentally using the "protect" button on the camera to prevent deletion of an image. When the images are downloaded to the PC they show up as read-only in the file system.
     
  16. g_glip9

    g_glip9

    10
    Sep 24, 2008
    brookline, ma
  17. g_glip9

    g_glip9

    10
    Sep 24, 2008
    brookline, ma
    I have an older Compaq Win XP machine and have not ever had the file-save problem with any software other than NX2: NX1 worked fine. Plus I am only reading and writing to my internal hard drive.
     
  18. otipher

    otipher

    8
    Jul 19, 2008
    NJ
    Problem fixed for remote drives in 2.1.1?

    Another update - I recently tried editing remote files and after initially still experiencing the problem I upgraded to the latest CaptureNX version 2.1.1. Since then I have edited 100+ remote files plus ran batch scripts with 30 files and touch wood not a single file error.

    Folks who used to experience this file problem on their remote drives may also want to report their experiences with 2.1.1.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.