1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

Poopy Day

Discussion in 'Film Forum' started by gbenic, Apr 28, 2007.

  1. My "new" Nikon L35AF2 arrived today. I replaced the batteries and played around. Everything was working great. Even the self timer worked out. I put a roll of film in it. Took a shot of my kid in her new sunglasses. Went out to get some shots of her on her skateboard. Pushed the shutter button, the shutter opened and never closed. The button is stuck down as well. Replaced the batteries again. No change. Removed the film to see if something got stuck in there. Nope. Shutter is still open. Button is still stuck down. Sometimes I really hate eBay. Now I know why it was so cheap. I even asked the seller if it worked. He replied that it did. My initial testing showed it worked too. It just doesn't like film.


    P.S. Can I salvage the film or is it ruined?
  2. sfoxjohn


    May 1, 2005
    Marlton, NJ
    Hi Greg,

    (John from Longwood Gdns last year.)

    I think I read that you "removed the film". Were you able to rewind before you did that? (I'm not trying to insult your intelligence) That part of the roll inside the cartridge should be OK. Waste the first two just to be sure.

    I'm going to send a PM
  3. Hey John, how ya doin'?

    I did remove the film, cut off the excess, and loaded it into my P&S. It did work out okay. Well, I only like one shot. But the film worked.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.