Poopy Day

Joined
Jun 5, 2005
Messages
4,437
Location
Denver, Pennsylvania, uSA
My "new" Nikon L35AF2 arrived today. I replaced the batteries and played around. Everything was working great. Even the self timer worked out. I put a roll of film in it. Took a shot of my kid in her new sunglasses. Went out to get some shots of her on her skateboard. Pushed the shutter button, the shutter opened and never closed. The button is stuck down as well. Replaced the batteries again. No change. Removed the film to see if something got stuck in there. Nope. Shutter is still open. Button is still stuck down. Sometimes I really hate eBay. Now I know why it was so cheap. I even asked the seller if it worked. He replied that it did. My initial testing showed it worked too. It just doesn't like film.

Crap!

P.S. Can I salvage the film or is it ruined?
 
Joined
May 1, 2005
Messages
1,804
Location
Marlton, NJ
Hi Greg,

(John from Longwood Gdns last year.)

I think I read that you "removed the film". Were you able to rewind before you did that? (I'm not trying to insult your intelligence) That part of the roll inside the cartridge should be OK. Waste the first two just to be sure.

I'm going to send a PM
 
Joined
Jun 5, 2005
Messages
4,437
Location
Denver, Pennsylvania, uSA
Hey John, how ya doin'?

I did remove the film, cut off the excess, and loaded it into my P&S. It did work out okay. Well, I only like one shot. But the film worked.
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom