Problem, D90 flash wont latch down..

Joined
May 17, 2009
Messages
20
Location
Portland Or.
I was using my D90 at the beer festival here in Portland and popped the flash for some fill, but now it wont close. Nothing happened to it, never dropped or bumped. It just wont latch shut now.

I found a couple references from others online so it has apparently happened to other too. What I was wondering is if theirs anyway to get the camera fixed without having to just loose out on it for a few months. Loosing it during summer would be horrible, and I have my "almost" bro-inlaws wedding to shoot in august.

I upgraded to this from a sony A300 on May 31st, so its been too long to just take it back to the store now.

Any advice on what I should do about it?
 
Joined
Jan 23, 2007
Messages
300
Location
West Virginia
Although I've not had an occasion to contact Nikon tech/customer support, seems like it may be a good first stop to get their perspective.
 
Joined
May 17, 2009
Messages
20
Location
Portland Or.
Im gonna try giving them a call in the morning, but Im just expecting them to say "send it in"... I really dont want to be camera-less for how ever long that takes..
 
Joined
Jan 23, 2007
Messages
300
Location
West Virginia
Completely understand about being without gear. I'm currently without my 80-200 2.8....it's getting a clean up/tune up from KEH.

Best of luck!
 
Joined
May 17, 2009
Messages
20
Location
Portland Or.
I called Nikon and of course they said I had to send it in. Im still not sure what the deal is with me having to pay shipping to get my camera fixed under warrenty, but oh well, I just want my camera to work.

They said their would be a 7-10 day turn around, so it looks like Ill be without it for ~2 weeks.
 
Joined
Feb 25, 2009
Messages
324
Location
Independence, Mo.
Chuckle, chuckle, 7-10 days...don't count on it. Mines been gone for a week and they still haven't logged it into the system and that was with second day delivery. Snicker...
 
Joined
May 17, 2009
Messages
20
Location
Portland Or.
Chuckle, chuckle, 7-10 days...don't count on it. Mines been gone for a week and they still haven't logged it into the system and that was with second day delivery. Snicker...


/cry ... Well that sucks. Im packing it up right now to send out. Id be thrilled if I got it back in 2 weeks now.

What did you send yours in for?
 
Joined
Feb 25, 2009
Messages
324
Location
Independence, Mo.
Mine freezes up after about 120 shots, just stops working. Sent it in the first part of June. Took 3+ weeks turn-around to get it back. Came back with notation that they couldn't replicate the problem. Used it a couple of times, both times it did the same thing. So it is now back in El Segundo. Has been 1+ week and so far, no word from them. Hoping this time they will resolve the problem.
 
Joined
Nov 18, 2008
Messages
1,211
Location
HHI
Chuckle, chuckle, 7-10 days...don't count on it. Mines been gone for a week and they still haven't logged it into the system and that was with second day delivery. Snicker...

I sent in a lens not long ago. It took 7-10 days before the "estimate accepted" status changed and it was shipped 2 days later. Time between me mailing out and having it returned was close to 3 weeks. At least it came back repaired to my satisfaction. GH
 
Joined
Mar 3, 2006
Messages
1,308
Location
Asheville, N.C.
I know this soundz bizarre, but try it before sending it to Nikon......replace with fully charged battery, turn camera setting to P , turn it on, turn to M , see if it will close, turn off......maybe???
 
Joined
May 17, 2009
Messages
20
Location
Portland Or.
Doh, sent it out yesterday..

I dont know if its just me, but I find it annoying I have to pay to have a warrantied item fixed ($30 to ship it fully insured)
 
Joined
Feb 25, 2009
Messages
324
Location
Independence, Mo.
You did the right thing on the insurance. The first time mine went it they wanted camera and lens. Cost $53 to ship it, but the piece of mind was worth it.

Yesterday I had to call them, it had been 8 days and still no acceptance notice. Got the you've got to be patient speach. I reminded them that since this was its second trip for the same problem that they promised priority treatment, got a post later last night. So at least it's in the shop.
 
Joined
May 17, 2009
Messages
20
Location
Portland Or.
Just an update. I shipped it out on Tuesday of last week and it got there Friday. Called on Monday and they said I have to give them 48 business hours for it to get processed and into the system.

Wednesday literally 2 minutes before I was gonna call I got an email with a service number. I looked it up and it said I was covered under warranty (Of course), so i just thought Id wait a while and see what changes. Looked today and the service number just says either its not valid or the item has been repaired.

Im hoping that its repaired and on its way back..Cross fingers
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom