Problem with Nikon 300 strap rings

Joined
Apr 15, 2008
Messages
140
Location
Canada
Greetings, all.

I've purchased a 300 2.8 AF-S II lens (non-VR) and the seller had camo lens coat on it. I look funny in a hockey rink with camo, so I took it off. :)

Actually, I wanted to use the strap rings on the lens for added protection. He had removed them to put the lens coat on. I've tried to screw them back on, but the screws just slide into the hole and there's nothing to receive them on the inside.

Obviously, the strap rings mount to the tripod ring and the only thing below that is the lens, itself.

What is supposed to be on the backside of the tripod mount for the screws to mount into? I'm thinking there would be a receiver plate with holes, but there isn't anything and I can't get the tripod mount off to check.

Anyone have any ideas? I'm at a total loss, as is the guy I bought it from.

Thanks for any help you can provide.

Mark
 
Joined
Mar 31, 2007
Messages
3,533
Location
Thornhill, Ontario, a suburb of Toronto
Greetings, all.

I've purchased a 300 2.8 AF-S II lens (non-VR) and the seller had camo lens coat on it. I look funny in a hockey rink with camo, so I took it off. :)

Actually, I wanted to use the strap rings on the lens for added protection. He had removed them to put the lens coat on. I've tried to screw them back on, but the screws just slide into the hole and there's nothing to receive them on the inside.

Obviously, the strap rings mount to the tripod ring and the only thing below that is the lens, itself.

What is supposed to be on the backside of the tripod mount for the screws to mount into? I'm thinking there would be a receiver plate with holes, but there isn't anything and I can't get the tripod mount off to check.

Anyone have any ideas? I'm at a total loss, as is the guy I bought it from.

Thanks for any help you can provide.

Mark
Why not ask the folks at Nikon Canada?
 
Joined
Apr 15, 2008
Messages
140
Location
Canada
  • Thread Starter Thread Starter
  • #3
Tried that. They, or any other Nikon repair facility, will not give out advise over the phone or without seeing it. In other words, you gotta pay.
 
Joined
Jan 2, 2009
Messages
5,508
Location
Alaska
Are you using the original screws? Also is it the original foot/ring or a replacement from RRS or Kirk?(not sure if they acutally make the ring for that model or just the foot). Basically trying to get at whether the screws you have match the holes :confused:
 
Joined
Apr 15, 2008
Messages
140
Location
Canada
  • Thread Starter Thread Starter
  • #5
The seller says all he did was unscrew the strap rings and apply the lens coat. The tripod ring and screws are original.
 
Joined
Jan 25, 2009
Messages
1,496
If you shake the lens, is there any rattling inside? Maybe the backing plate for the screws has settled into a corner of the tripod mount... if you shake it loose maybe you can rotate the lens to align the plate to the hole, and then catch it with the original screw.
 
Joined
Apr 15, 2008
Messages
140
Location
Canada
  • Thread Starter Thread Starter
  • #7
Now that you mention it, Eric. I recall that when I loosen up the lock nut on the tripod ring I did hear something that wasn't right; maybe something sliding around.

I won't be able to check this until later tonight, but I think you're on to something there. There has to be a backing plate to screw into and I bet it could be hidden under that ring.

Now I can't wait to get home and check that out! :)

Mark
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom