1. Welcome to NikonCafe.com—a friendly Nikon camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

Problems with D700/ mb-d10 focus point

Discussion in 'Nikon FX DSLR Forum' started by xenonsupra, Jul 28, 2009.

  1. As of about a week ago, I'm having some problems with my Mb-D10 on my D700.

    When the grip is attached I'm trying to move my focus point using the multi-selector on the grip. The focus point simply won't move at all. It moves fine using the one on the d700 body, and I'm 100% certain the focus point "lock" isn't in use.

    I've recharged the batteries and removed the grip and put it back on several times.

    Any suggestions what may be the problem? I could be wrong but I don't think there is a camera setting to toggle it on/off.

    Thanks.
     
  2. kaska

    kaska

    204
    Apr 17, 2009
    NY
    That is weird. Have you tried accessing menu using the directional pad on the mb-d10?
     
  3. Are the two white marks on the switch around the shutter release button on the grip lined up?


    Karl
     
  4. ibcj

    ibcj

    732
    Dec 19, 2006
    New York
    Joey - I can't offer any suggestions that you probably haven't tried, but I can say that I've noticed this type of behavior occasionally when I had a MB-D10 on my D300 and D700. It usually resolved itself after turning the camera on and off. It was frustrating, and the grip was one of the big reasons I went to the D3. Hope you can find a solution to this one.
     
  5. bigwilly

    bigwilly

    143
    Oct 19, 2007
    Toronto
    Maybe obvious, but do the other buttons on the grip work? Is the grip turned on?
     
  6. Thanks everyone for the tips, but it's still not working.
    The grip is not turned off, the shutter still works...
    The AF-ON does not work, nor does the joystick on the navigational menu.

    I guess I'll try it on someone elses D700/300 and then if it still isn't working I'll send it in to Nikon. I bought it last september, I assume it has at least a 1 year warranty?
     
  7. Tim W

    Tim W

    704
    Mar 10, 2008
    Sydney, Australia
    I assume you have tried cleaning all the contacts. It might be worth a try if you haven't.
     
  8. I seem to be having the same problems with my grip - just got it a week ago and first time playing with it. Multi-selector just doesn't seem to want to move the sensors around. It's frustrating. All other buttons af-on works fine. Any ideas on what could be wrong?
     
  9. TheShotLessTaken

    TheShotLessTaken

    303
    Oct 2, 2008
    SoCal
    A lot of problem threads lately.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.