Sandisk SD card problem!

Discussion in 'General Discussion' started by alexf, Jun 11, 2007.

  1. I've had a Sandisk SD Extreme III 2GB for a few months now. Never a problem until today.

    I had about 180 shots in it from the weekend. I connected the camera as always (USB cable on D80 - I don't have an SD USB-drive).

    As usual, I moved the files to the hard drive (Windows Explorer WinXP). After a while it stopped with an error that it could not read the file. I tried with another file, same error.

    After several tests, I have a corrupted card with 84 photos left in it. I can see and browse through them in the camera itself. I cannot delete in the camera. I get a card error.

    The card is not locked (lock tab is off). I decided to lose them and try to save the card. I did a format in the D80 itself. It went through the motions but it did not format, as the card does not show empty. No matter what, the photos are there and I can still cycle through them in the camera. No go on moving/copying/deleting them

    Any ideas? I'd hate to lose the card. It ain't cheap. :mad:
     
    Last edited by a moderator: Jun 11, 2007
  2. gadgetguy11

    gadgetguy11

    Nov 16, 2005
    Kentucky
    Get the card to a card reader so you can isolate the trouble as follows:

    1-Card
    2-Camera
    3-Cable
    4-Computer
    5-Windows OS

    This may mean a drive to your local camera shop, try your card in their camera or computer / card reader, buying your own card reader, or testing a 2nd card - see below.

    Did you power down camera when you plugged the cable / unplugged it? I fried an Olympus by NOT powering down. Apparently the USB which is hot swappable is not so on cameras... If you did NOT, you could have fried the USB output driver on your camera.

    Could just be the card. You will find out when you get to a card reader. You can BUY a card reader for about $20; plug it into a USB port, then you will eliminate the camera and cable.

    Since the odd operation is camera / card based, it is one of those 2.

    One last option. Get another card. Take pics, try to format over them in camera. If all is well, plug the camera (powered down first) into the computer. If all works well, you have a bad first card.

    Sandisk has a LIFETIME WARRANTY - Google Sandisk and look for warranty resolution - Sandisk will exchange it N/C.

    All the best,

    John
     
  3. KrysiaG

    KrysiaG Guest

    I have had similar problems with my Sandisk, as well. The photos were there, but I couldn't get them off the chip.

    I hope you were able to figure this out.
     
  4. gadgetguy11

    gadgetguy11

    Nov 16, 2005
    Kentucky
    We PM'ed several times. alexf had a 2nd card that worked fine, that proved his 1st card is bad. Meanwhile, some of Sandisk advertising, especially for faster, premium cards, is still lifetime warranty, but 5 year warranty is now on the website. Fortunately his card is a 2006 model. Return for exchange instructions are on the Internet, just Google Sandisk.
    Here is an excerpt:

    To obtain warranty service contact SanDisk at 1-866-SanDisk or send an email to: support@sandisk.com during the Warranty Period. You must obtain a tracking confirmation number and return the product in tamper resistant packaging, freight prepaid, as instructed by SanDisk. SanDisk will, at its option, repair or replace the product with new or refurbished product of equal or greater capacity and functionality, or refund your purchase price, less any rebates. The warranty duration on any replaced product will be that portion of the Warranty Period remaining on your original product.


    Good luck!

    John

     
  5. Gale

    Gale

    978
    Jan 26, 2005
    Viera Fl
    Last edited by a moderator: Mar 15, 2017
  6. Well, I received an USB drive from Amazon today, SanDisk 12-in-1 and it read the card.

    Whatever the problem was seems to be fixed.

    I copied the photos out, now will try to format the SD card again.

    Thanks, John for the help.

    [Update] Spoke too son. The photos were retrieved successfully but the card does not format. Seems to have a corruption in the file allocation table. It shows 67 files, a mix of JPG and NEF I had before, but all with 0 length. I can erase them from Windows Explorer. When I try to erase the folder in the card, it says it can cos the folder is not empty, then like magic, the folder fills up with the same 67 0-length files. Did it twice.

    Formatting in the camera has the same effect. Still shows less capacity than an empty card and all 0-length files are there. I guess I have to talk to SanDisk.
     
    Last edited by a moderator: Jun 15, 2007
  7. gadgetguy11

    gadgetguy11

    Nov 16, 2005
    Kentucky
    Glad to help, Alex! Glad you were able to copy your photos from the card - that is an unexpected bonus!
     
  8. Nope. See the update posted above, just as you were answering.
     
Loading...
Similar Threads Forum Date
Sandisk Extreme III SD card failure General Discussion Nov 2, 2010
SanDisk Ultra 32GB SD card heads up General Discussion Jan 14, 2010
Heads up - 8GB SanDisk CF cards $26.99 at Costco (also SD cards) General Discussion Jan 10, 2010
SanDisk Buy One, Get One 2GB Ultra II CF and SD cards General Discussion Jul 24, 2007