1. I've read about plenty of you using your SB-800 in the TTL-BL mode, esp. for outdoor fill... I have looked in the manual and tried to use the mode button, but all I can get is TTL... how do I get it to show the BL? Thanks!
     
  2. nicktak

    nicktak

    75
    Jul 30, 2006
    I think TTL-BL doesn't work when your camera is in M mode.
    Does it show up when you're in A, S or P mode?
     
  3. fyrbolt

    fyrbolt

    102
    Feb 2, 2007
    Las Vegas
    A good place to start is by describing your camera settings. Whether your flash is on the camera or not when you are changing your mode. The flash won't show the BL if it's not on the camera or if the camera isn't on.
     
  4. Frank R

    Frank R

    318
    Feb 18, 2006
    Long Island NY
    You have to have your camera set to matrix metering. :smile:
     
  5. Cope

    Cope

    Apr 5, 2007
    Houston, Texas
    Mine goes to BL in either matrix or center-weighted, but not in spot metering.

    It works in any exposure mode (PASM). This is on the D200 other models may vary; see the chart on pp. 108-110 of the SB-800 manual.
     
  6. Cope

    Cope

    Apr 5, 2007
    Houston, Texas
    It will not show FP or BL unless powered up on camera.
     
  7. Will give it a shot really quickly, as I usually leave mine in M.

    I'm talking about when it's attached to the camera and both are on.

    Hmm... OK, well, I usually use spot, so I guess I'll have to change that for certain occasions. Thanks, guys!
     
  8. That's incorrect, Nicktak. TTL-BL works in all modes... M, A, S, and P. The only restriction is that it won't work in any mode if you're using spot metering. You must be using matrix or center weighted metering.
     
    Last edited by a moderator: Jun 25, 2007
  9. fyrbolt

    fyrbolt

    102
    Feb 2, 2007
    Las Vegas
    Shaun, have you fixed the problem? I'm curious to know in case I run into the same problem...
     
  10. nicktak

    nicktak

    75
    Jul 30, 2006
    Yep, sorry for my incorrect response. The issue is the metering. I usually use spot metering so I incorrectly assumed it was because I was in M mode.

    Thankfully there are smarter people here than myself. :)
     
  11. I'm flattered, but it had nothing to do with being smart. I just stapped an sb800 on my d200, and checked to see which modes supported iTTL/bl. It only took a 1 minute investment to become a flash guru :cool:.
     
  12. Well, you ARE the flash guru here, U.F.!!! :biggrin: But I tried the same thing without knowing the answer and never found the solution, you know, the most obvious and all that... changing metering modes for me is a foreign concept... I learned spot, and have never changed back... it only takes a second for me to get much more consistent results than with matrix, and I still haven't figured center-weighted!!! :frown: So some of us do have to ask the occasional questions! :smile: :wink:
     
Loading...
Similar Threads Forum Date
Need help, SB-800, D500, Better Beamer, ISO settings and best practice General flash photography, lighting, and technique Jun 11, 2017
SB-600 delay w/SB-700 master help General flash photography, lighting, and technique Aug 13, 2012
Need SB 900 help General flash photography, lighting, and technique Feb 11, 2012
HELP; SB-800 frustration General flash photography, lighting, and technique Feb 1, 2012
HELP! SB-600 stuck in remote mode ... General flash photography, lighting, and technique May 25, 2011