Sigma 1.4x TC question

Joined
Sep 20, 2007
Messages
307
Location
So. Cal.
I have a question about the functionality of a Sigma 1.4x teleconverter I bought used. Anyway, I took it out of it's pouch and was going to mount it onto my D80. I noticed the aperature lever on the camera side moves freely from side to side (in a circular movement) with no resistance. Now the lens side offers resistance when I move it from side to side with my finger. Is this functioning correctly? Is the back lever broken or is this normal? I don't own a Sigma lens yet to try it out so I had to ask.

Thanks,

Rob
 
Joined
Jun 14, 2006
Messages
538
Location
Bedfordshire, UK
A Sigma TC will not work with most non-Sigma lenses as the contacts pass data to the lens a bit differently than Nikon or Kenko TCs do.
I think he means the lever that connect the lens' aperture lever to the camera's actuating arm.

--

OP, if you mount a lens on the TC and manually move the control lever, does the lens' iris move as expected?

Perhaps there is just a little extra movement on the camera side for tolerance?
 
Joined
Sep 20, 2007
Messages
307
Location
So. Cal.
I think he means the lever that connect the lens' aperture lever to the camera's actuating arm.

--

OP, if you mount a lens on the TC and manually move the control lever, does the lens' iris move as expected?

Perhaps there is just a little extra movement on the camera side for tolerance?
Yes, that is it. Sorry about my bad description. I don't have a compatible Sigma lens to try it out yet but I believe your answer to be correct. Anyway, I'm planning on getting a Sigma 100-300 f4 real soon, so I'll know then.

Thanks for the repies guys.

Rob
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom