Spots in view finder but no spots on images...

Joined
Apr 25, 2008
Messages
3,086
Location
NJ
I just cleaned my sensor and I noticed some spots visible in the view finder...
So I took a bunch of sample pictures and they are perfectly clean! Anyone have any idea what this is or how to fix it?
 
Joined
Apr 25, 2008
Messages
3,086
Location
NJ
Guess it's just some gunk on the inside somewhere. Nikon could probably clean it up. I'm going to be sending my camera out for cleaning after my vacation is over in a couple weeks, I'll make sure they take care of it.
 
Joined
Jul 20, 2007
Messages
4,047
Location
UK
It's likely to be either on the mirror or the focusing screen.

A blower will probabally get the worst of it off.
 
Joined
Nov 15, 2006
Messages
544
Location
Winter Haven, Florida
I will concur with Robert. Had this occur to me on my D50. Simply remove the lens and use a "rocket blower" to remove th dust. Should take car of it...it did on my camera.
 
Joined
Jul 20, 2007
Messages
4,047
Location
UK
I have a dust bunnie on my viewfinder as well, no big deal, but, annoying !!
The actual spots don't annoy me so much, it's when little fibres get into the camera and I get a "hairy" focusing screen that annoys me!
 
Joined
Apr 25, 2008
Messages
3,086
Location
NJ
The actual spots don't annoy me so much, it's when little fibres get into the camera and I get a "hairy" focusing screen that annoys me!
yeah I had one of those, but it came off with a good blow from the rocket blower.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom