Strange 'Messages' behavior

Joined
May 5, 2005
Messages
22,460
Location
SW Virginia
I and my wife have both recently gotten text messages from friends that never show up on our iPhones. I have found them when I open the "Messages" app on my computer, including messages to her.

We share a common iCloud account which is registered to me.

Any idea how this happens?
 
Joined
May 5, 2005
Messages
22,460
Location
SW Virginia
  • Thread Starter Thread Starter
  • #2
I think I've got this fixed now. My wife and I both got new iPhones about a month ago. I just discovered that "iMessage" was turned off on both phones. Never realized this wouldn't be on by default on a new phone.
 
Joined
Jan 3, 2007
Messages
3,081
Location
Tacoma, WA
Real Name
Ken St John
That did come to mind, and it is odd, isn't it? Something else I do with iMessage which has helped is I have disabled the "you can be reached at" in Settings/Preferences to just my phone number, not any of my email addresses. I do that on our phones as well as on my Mac's. Seems to help keep things straight!!

Cheers!!

Ken
 
Joined
Oct 15, 2008
Messages
2,278
Location
GA
That did come to mind, and it is odd, isn't it? Something else I do with iMessage which has helped is I have disabled the "you can be reached at" in Settings/Preferences to just my phone number, not any of my email addresses. I do that on our phones as well as on my Mac's. Seems to help keep things straight!!

Cheers!!

Ken
Well, in his case, he has to turn that off since he and his wife share the same account.

iMessage not being on by default is a little strange though.
 
Joined
Sep 19, 2011
Messages
1,209
Location
Ireland
The iPhone does receive messages if iMessage is turned off. Difference is iMessage uses a WiFi connection and encrypts through Apple and iMessage off uses normal cellular connection. There’s a specific toggle in settings to send as sms if iMessage is unavailable when iMessage is on. So you should still have received messages.
interestingly as an opposite to your experience I always turn off iMessage as I find the receipt and sending of messages unreliable with iMessage on ie. undelivered messages in both directions.
 
Joined
May 5, 2005
Messages
22,460
Location
SW Virginia
  • Thread Starter Thread Starter
  • #8
It appears that "Send as SMS" is also turned off by default. But we are discussing receiving messages, not sending, as you said.

All I know is texts were only coming to Messages on the Mac until I turned on iMessage. Then they started coming to the phones.
 
Joined
May 5, 2005
Messages
22,460
Location
SW Virginia
  • Thread Starter Thread Starter
  • #9
This is from Apple:

You cannot receive iMessages if it is not enabled. iMessages is an Apple app that works over WiFi. If you turn it off, you can't send or receive iMessages. You can send and receive standard SMS messages via your wireless cellular provider assuming that you have a plan that includes texting.

So I guess the texts that we were not getting were all sent as iMessages, not as SMS.
 
Joined
Mar 25, 2011
Messages
2,676
Location
London
The iPhone does receive messages if iMessage is turned off. Difference is iMessage uses a WiFi connection and encrypts through Apple and iMessage off uses normal cellular connection. There’s a specific toggle in settings to send as sms if iMessage is unavailable when iMessage is on. So you should still have received messages.
interestingly as an opposite to your experience I always turn off iMessage as I find the receipt and sending of messages unreliable with iMessage on ie. undelivered messages in both directions.
iMessage also works on cellular/mobile. In addition to WiFi.
There are several quirks with it, especially if moving away from the IOS ecosystem, these are well documented on many sites.
I am on Three UK and iMessage works all the time, Wifi on or off.
I receive messages on iPads, iPhones, and MacBook Pro.
Integration is superb.
 
Joined
Oct 15, 2008
Messages
2,278
Location
GA
This is from Apple:

You cannot receive iMessages if it is not enabled. iMessages is an Apple app that works over WiFi. If you turn it off, you can't send or receive iMessages. You can send and receive standard SMS messages via your wireless cellular provider assuming that you have a plan that includes texting.

So I guess the texts that we were not getting were all sent as iMessages, not as SMS.
Actually i'm pretty sure I know what happened.

You likely set up iMessage with your old phone. When you do this, your number/account is then associated by Apple as being iMessage vs. SMS. Your new phone had this turned off, which means no iMessage type "texts" would come through until you turn it on. Regular SMS, however, would have since that's carrier based.

When you setup iMessage, you essentially "opt in" to the service. Opting out isn't automatic, at least not right away. You either have to force it by turning it off before disconnecting your account from an old device, or you wait a while for it to unassign you automatically. However, since your laptop was still receiving them, the automatic opt out would have taken much longer.

This is a huge issue for people who switch from iPhone to Android since the sender will still "see" you as being iMessage capable but your new device isn't so the texts go into limbo and never get delivered. Eventually that service will recognize they aren't being delivered and they unassign you.
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom