Wierd user/admin problem

Joined
Jul 30, 2006
Messages
11,635
Location
Southern California
So, I recently got some film scans back on CD... I tried to make changes to the pics in PS, but was not allowed to save the changes, as my computer "told" me I didn't have proper permissions. So I opened the folder in Finder, went to Get Info... And here's the wierd part. The (me) name for my privileges is different from my Admin name, but I'm logged in on my Admin account. I don't even recognize the (me) name attached there. Can anyone tell me what's going on or how to fix it? Thanks!!!
 
Joined
Feb 28, 2006
Messages
1,401
Location
Seattle WA
Are you comfortable in a Unix Terminal window and a command line interface a la DOS cmd? If so I can help.
 
Your machine is a used one, right? My guess is that for some reason some permissions are still in the name of the former owner/user? When you got the machine, did you do a complete wipe and clean install of the software or are you using it as delivered from the previous owner?

Unfortunately I have no idea of how to help correct this problem unless to do a complete wipe-and-clean-install. ??

Ah...wait. OK, so you got the scans back on CD. Maybe the name and the permissions are in the name of whoever it was who processed the scans and put them on CD????
 
Joined
May 3, 2009
Messages
211
Location
North Carolina
Did you open the scans directly from the CD, or did you copy them to your computer first?

Did you try to save changes to the original file, or did you use the Save As command?

Sometimes, if you can't save the original (and you wouldn't be able to if you had opened it directly off the CD), you can use the Save As command and save a copy (I assume Photoshop, but it should work in another program as well).

We have problems at work with editing word processing files. A lot of times, the Save As command is the answer.

Now if you've already tried that, then you may have to muck around in the file's Get Info box in the Finder...

Hope this helps.

Andy
 
Joined
Jul 30, 2006
Messages
11,635
Location
Southern California
  • Thread Starter Thread Starter
  • #6
Your machine is a used one, right? My guess is that for some reason some permissions are still in the name of the former owner/user? When you got the machine, did you do a complete wipe and clean install of the software or are you using it as delivered from the previous owner?

Unfortunately I have no idea of how to help correct this problem unless to do a complete wipe-and-clean-install. ??

Ah...wait. OK, so you got the scans back on CD. Maybe the name and the permissions are in the name of whoever it was who processed the scans and put them on CD????
I did do a complete wipe, clean, reinstall, etc. when I bought the machine.

Did you open the scans directly from the CD, or did you copy them to your computer first?

Did you try to save changes to the original file, or did you use the Save As command?

Sometimes, if you can't save the original (and you wouldn't be able to if you had opened it directly off the CD), you can use the Save As command and save a copy (I assume Photoshop, but it should work in another program as well).

We have problems at work with editing word processing files. A lot of times, the Save As command is the answer.

Now if you've already tried that, then you may have to muck around in the file's Get Info box in the Finder...

Hope this helps.

Andy
I tried versions of saving. I can actually change the permissions in the Get Info box, but I have to do this individually for each picture, and I'm not willing to spend the time. I tried to change it for each picture folder, but that didn't work.

try this - the easy-cheapo-quick-fix attempt w/o using the Terminal/Command-Line:

1. Create a new folder
2. Copy the files to that folder
3. Check the permissions of one just file and check the permissions. They should be similar to your(me) and the admin account.
4. If not and you do not like change anything on your systems setup, download the application BatCHMOD.
5. Read the page before you use it!
6. Point BatCHMOD to the dedicated golfer where the file reside and change the permissions all to R/W/X, and mark all checks, including those of "Options" as well as the last one, which lets BatCHMOF execute the chmod command to all filed inside the folder with the pictures.
7. BatCHMOD will change all permissions to all files.
8. If you like the application, make a donation, it is worth it!

BatCHMOD is just a "visualisation" of the chmod command, including its available options that you would have entered on the command line.

If this helps, then open the "Disk Utility" and excite the "Disk Utility", found in the "Utilities" subfolder inside "Applications" or hit "apple-U = apple-shift-u" and let the "Disk Utility" let "Repair Permissions" on your system.

saludos redondos
tom
I will have to give this a try when I have more time and am not so tired. :smile: Thanks you!
 
Joined
Jan 13, 2006
Messages
4,586
Location
Columbia, Maryland
Real Name
Walter Rowe
Go into Applications > Utilities > Disk Utility
Select your hard drive
Run "Repair Permissions"

The files may show the owner of the people who did the scans for you. When you copied the files from the CD to your hard disk, the ownership and permissions might have come over with them.
 
Joined
May 3, 2009
Messages
211
Location
North Carolina
Shaun,

Since you can change the permissions on each file, you might try this.

Put all the photos in one folder. And then, because I'm paranoid, duplicate the folder (in case it doesn't work, you still have the photos with permissions unaltered).

Now go to the Get Info box for the folder (the folder, not the contents).

Set the permissions you want.

Now, at the bottom of the Get Info box, there is a little gear. Click on it, and you will see an option to apply to enclosed items. Do that, and it should change the permissions for every file in that folder.

See if that solves the problem. Like I said, do it after you've made a duplicate (just in case). If it works, then you can keep the duplicate folder and delete the original. If it doesn't work, you still have the originals.

Of course, if you have already tried Tom's method and it worked, then all is good for you.

Hope this works for you.

Andy
 
Joined
Jul 30, 2006
Messages
11,635
Location
Southern California
  • Thread Starter Thread Starter
  • #9
Shaun,

Since you can change the permissions on each file, you might try this.

Put all the photos in one folder. And then, because I'm paranoid, duplicate the folder (in case it doesn't work, you still have the photos with permissions unaltered).

Now go to the Get Info box for the folder (the folder, not the contents).

Set the permissions you want.

Now, at the bottom of the Get Info box, there is a little gear. Click on it, and you will see an option to apply to enclosed items. Do that, and it should change the permissions for every file in that folder.

See if that solves the problem. Like I said, do it after you've made a duplicate (just in case). If it works, then you can keep the duplicate folder and delete the original. If it doesn't work, you still have the originals.

Of course, if you have already tried Tom's method and it worked, then all is good for you.

Hope this works for you.

Andy
Thanks, Andy, this was the easy "for-now" fix. But I still have a problem, and I think it's connected to my accounts somehow... see below.
 
Joined
Jul 30, 2006
Messages
11,635
Location
Southern California
  • Thread Starter Thread Starter
  • #10
try this - the easy-cheapo-quick-fix attempt w/o using the Terminal/Command-Line:

1. Create a new folder
2. Copy the files to that folder
3. Check the permissions of one just file and check the permissions. They should be similar to your(me) and the admin account.
4. If not and you do not like change anything on your systems setup, download the application BatCHMOD.
5. Read the page before you use it!
6. Point BatCHMOD to the dedicated golfer where the file reside and change the permissions all to R/W/X, and mark all checks, including those of "Options" as well as the last one, which lets BatCHMOF execute the chmod command to all filed inside the folder with the pictures.
7. BatCHMOD will change all permissions to all files.
8. If you like the application, make a donation, it is worth it!

BatCHMOD is just a "visualisation" of the chmod command, including its available options that you would have entered on the command line.

If this helps, then open the "Disk Utility" and excite the "Disk Utility", found in the "Utilities" subfolder inside "Applications" or hit "apple-U = apple-shift-u" and let the "Disk Utility" let "Repair Permissions" on your system.

saludos redondos
tom
I just re-read your post more carefully, and I think this is where my problem lies. When I go to >Get Info, it shows the admin? account as one versions, but when I go into >Settings>Accounts it shows the admin account name as something different. How is this possible and how to I change it to match?
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Nikon Cafe is a fan site and not associated with Nikon Corporation.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2005-2019 Amin Forums, LLC
Top Bottom