Yongnuo 622N TX conntroller

Discussion in 'General flash photography, lighting, and technique' started by cjackson, Feb 11, 2018.

  1. cjackson

    cjackson

    95
    Jan 13, 2009
    USA
    I cannot get my controller to initiate the flash. Flash is attached to 622N-ittl Transceiver. Flash on transceiver flashes when transceiver test button is pushed. Flash on controller flashes when controller test button is pressed. But when I press shutter, no flash is initiated.
     
  2. TonyW

    TonyW

    Jan 15, 2010
    UK
    Long time since I used the 622's but a question or two:

    Just so that I am absolutely clear on what set up you have. You are using 2 Yongnuo 622's, one on camera acting as transmitter and one with a flash attached acting as a receiver?
    Assuming this it the case:
    • Is the camera set at the maximum flash sync speed or lower (1/250 sec or lower D800)?

    • Is the group setting the same on both units e.g. both set to 'A'? Similarly for the channel settings

    • As this scenario is remote control are you setting the transmitter to i-TTL or Manual?

    • Have you tried both methods iTTL and Manual and are you using a Nikon flash unit?

    • Make sure that flash is awake before firing (a half press on shutter button should work)

    • I cannot remember if this is important but sometimes you will find that the sequence of turning on equipment will matter. You may want to try starting with all turned off. Turn transmitter on camera on first then turn on camera. Turn on receiver first then the attached flash. Note it may be a variation on this or may not make any difference!
    I still have my 622's but rarely use them (now Cactus V6II's). They worked just fine on my D800 and Nikon and Yongnuo (Nikon) flash iTTL or manual and also worked well with my Pentax with the Nikon flashes in manual mode only.
    Hope something here will help
     
  3. cjackson

    cjackson

    95
    Jan 13, 2009
    USA
    Flash speed is set to 1/200 sec, camera is D7100.
    Group and channel match.
    Transmitter set to iTTL. Per Yongnuo instructions flash set to TTL.
    Flash is awake before firing.
     
  4. TonyW

    TonyW

    Jan 15, 2010
    UK
    Well, it seems that these basics covered, so trying to think of other reasons for non firing I can only suggest you check the following:

    First assuming that with one 622n acting as transmitter unit attached to the camera hot shoe and the flash set up on the other 622n acting as a receiver when you press the test button on the 622n on camera the flash always fires, this would indicate that communication between units is fine. Therefore there must be some error between the camera sync and the 622n hopefully just relating to the settings

    1. Camera should be set to one of the program modes, P, A, S or M. Not 100% but I do not think the flash works in the scene modes
    2. Does the flash fire correctly when set directly on the camera hot shoe?
    3. If flash fires for the above will it fire when mounted on the 622 mounted on the camera hot shoe?
    4. Not familiar with the camera flash settings menu - is there anything there that may cause non firing of a flash fitted to hot shoe?
    5. Double check the manual (I cannot remember) to see if there is a particular setting for a 622 unit to be either a transmitter or receiver

    Hope there is something here that helps as I think I may have run out of ideas
     
Loading...
Similar Threads Forum Date
Yongnuo YN-622N not compatible with D2 series cameras? General flash photography, lighting, and technique Nov 3, 2014
Help with Yongnuo YN-622N-TX in BL mode General flash photography, lighting, and technique Jul 27, 2014
Yongnuo YN-622N TX focus assist light question General flash photography, lighting, and technique Jun 4, 2014
Yongnuo YN-622N Transeivers? General flash photography, lighting, and technique Apr 3, 2014
New Yongnuo YN-622N-TX flash controller General flash photography, lighting, and technique Feb 8, 2014